To check the basic network metrics that are used to calculate the application QoE, use the show performance monitor cache monitor APP_PM_POLICY-art_agg detail format record and show performance monitor cache monitor APP_PM_POLICY-media_agg detail format record commands.
Device# show performance monitor cache monitor APP_PM_POLICY-art_agg detail format record
Monitor: APP_PM_POLICY-art_agg
Data Collection Monitor:
Cache type: Synchronized (Platform cache)
Cache size: 112500
Current entries: 6
High Watermark: 6
Flows added: 6
Flows aged: 0
Synchronized timeout (secs): 300
FLOW DIRECTION: Output
TIMESTAMP MONITOR START: 14:10:00.000
FLOW OBSPOINT ID: 4294967298
INTERFACE OVERLAY SESSION ID OUTPUT: 0
IP VPN ID: 65535
APPLICATION NAME: layer7 share-point
connection server resp counter: 1477
connection to server netw delay sum: 10822 < --- SND_ samples
connection to server netw delay min: 100
connection to server netw delay max: 103
connection to client netw delay sum: 3559 < --- CND_ samples
connection to client netw delay min: 20
connection to client netw delay max: 198
connection application delay sum: 936
connection application delay min: 0
connection application delay max: 122
connection responder retrans packets: 2 <---- lost_samples
connection to server netw jitter mean: 0
connection count new: 108 < ---- SND/CND_total
connection server packets counter: 2018 <---- total_samples
Latency(SND ms) = SND_ samples/ SND/CND_total
Latency(CND ms) = CND_ samples/ SND/CND_total
Loss ratio = lost_samples /total_samples
Device# show performance monitor cache monitor APP_PM_POLICY-media_agg detail format record
Monitor: APP_PM_POLICY-media_agg
Data Collection Monitor:
Cache type: Synchronized (Platform cache)
Cache size: 40000
Current entries: 4
High Watermark: 4
Flows added: 4
Flows aged: 0
Synchronized timeout (secs): 300
FLOW DIRECTION: Input
TIMESTAMP MONITOR START: 14:20:00.000
FLOW OBSPOINT ID: 4294967310
INTERFACE OVERLAY SESSION ID INPUT: 132
IP VPN ID: 65535
APPLICATION NAME: layer7 rtp-video
trns counter packets lost rate: 0.00
trns counter packets expect: 4696 < --- total_ packets
trns counter packets lost: 0 < --- lost_ packets
rtp jitter inter arrival mean: 0
rtp jitter inter arrival samples: 4666 < --- jitter_samples
rtp jitter inter arrival sum: 108324570 < --- jitter_ sum
Loss ratio = lost_ packets /total_ packets
Jitter (us) = jitter_ sum/jitter_samples
To check if the application performance is enabled, use the show performance monitor context APP_PM_POLICY configuration command.
Device# show performance monitor context APP_PM_POLICY configuration
!===============================================================================
! Equivalent Configuration of Context APP_PM_POLICY !
!===============================================================================
!Exporters
!==========
!
flow exporter APP_PM_POLICY-1
description performance monitor context APP_PM_POLICY exporter
destination local sdwan
export-protocol ipfix
option application-table export-spread 0
!
!Access Lists
!=============
ip access-list extended APP_PM_POLICY-art_agg_tcp
permit tcp any any
!
ip access-list extended APP_PM_POLICY-media_agg_udp
permit udp any any
!
!Class-maps
!===========
class-map match-all APP_PM_POLICY-art_agg
match class-map APP_PERF_MONITOR_FILTERS
match access-group name APP_PM_POLICY-art_agg_tcp
!
class-map match-any APP_PM_POLICY-media_agg_app
match protocol rtp in-app-hierarchy
!
class-map match-all APP_PM_POLICY-media_agg
match class-map APP_PERF_MONITOR_FILTERS
match access-group name APP_PM_POLICY-media_agg_udp
match class-map APP_PM_POLICY-media_agg_app
!
!Samplers
!=========
sampler APP_PM_POLICY-art_agg
granularity connection
mode time-based 1 out-of 100
!
sampler APP_PM_POLICY-media_agg
granularity connection
mode time-based 1 out-of 100
!
!Records and Monitors
!=====================
!
flow record type performance-monitor APP_PM_POLICY-art_agg
description ezPM record
match flow direction
match application name
match timestamp absolute monitoring-interval start
match flow observation point
match overlay session id output
match routing vrf service
collect connection new-connections
collect connection server counter responses
collect connection delay network to-server sum
collect connection delay network to-server min
collect connection delay network to-server max
collect connection delay network to-client sum
collect connection delay network to-client min
collect connection delay network to-client max
collect connection delay application sum
collect connection delay application min
collect connection delay application max
collect connection server counter packets long
collect connection server counter packets retransmitted
collect connection jitter network to-server mean
!
!
flow monitor type performance-monitor APP_PM_POLICY-art_agg
record APP_PM_POLICY-art_agg
exporter APP_PM_POLICY-1
cache entries 2700
cache timeout synchronized 300 export-spread 150
!
!
flow record type performance-monitor APP_PM_POLICY-media_agg
description ezPM record
match flow direction
match application name
match timestamp absolute monitoring-interval start
match flow observation point
match overlay session id input
match routing vrf service
collect transport packets lost rate
collect transport rtp jitter inter-arrival mean
!
!
flow monitor type performance-monitor APP_PM_POLICY-media_agg
record APP_PM_POLICY-media_agg
exporter APP_PM_POLICY-1
cache entries 960
cache timeout synchronized 300 export-spread 150
!
!Policy-maps
!============
policy-map type performance-monitor APP_PM_POLICY-in
parameter default account-on-resolution
class APP_PM_POLICY-art_agg
flow monitor APP_PM_POLICY-art_agg sampler APP_PM_POLICY-art_agg
class APP_PM_POLICY-media_agg
flow monitor APP_PM_POLICY-media_agg sampler APP_PM_POLICY-media_agg
!
policy-map type performance-monitor APP_PM_POLICY-out
parameter default account-on-resolution
class APP_PM_POLICY-art_agg
flow monitor APP_PM_POLICY-art_agg sampler APP_PM_POLICY-art_agg
class APP_PM_POLICY-media_agg
flow monitor APP_PM_POLICY-media_agg sampler APP_PM_POLICY-media_agg
!
policy-map type performance-monitor APP_PM_POLICY-art-in
parameter default account-on-resolution
class APP_PM_POLICY-art_agg
flow monitor APP_PM_POLICY-art_agg sampler APP_PM_POLICY-art_agg
!
policy-map type performance-monitor APP_PM_POLICY-art-out
parameter default account-on-resolution
class APP_PM_POLICY-art_agg
flow monitor APP_PM_POLICY-art_agg sampler APP_PM_POLICY-art_agg
!
!Interface Attachments
!======================
interface Tunnel1
service-policy type performance-monitor input APP_PM_POLICY-in
service-policy type performance-monitor output APP_PM_POLICY-out
!
interface Tunnel4
service-policy type performance-monitor input APP_PM_POLICY-in
service-policy type performance-monitor output APP_PM_POLICY-out
!
interface GigabitEthernet1
service-policy type performance-monitor input APP_PM_POLICY-art-in
service-policy type performance-monitor output APP_PM_POLICY-art-out
!
interface GigabitEthernet4
service-policy type performance-monitor input APP_PM_POLICY-art-in
service-policy type performance-monitor output APP_PM_POLICY-art-out
!
interface Tunnel1000100
service-policy type performance-monitor input APP_PM_POLICY-art-in
service-policy type performance-monitor output APP_PM_POLICY-art-out
!
interface Tunnel1000200
service-policy type performance-monitor input APP_PM_POLICY-art-in
service-policy type performance-monitor output APP_PM_POLICY-art-out
!
To check pending object issues use the show platform software object-manager fp active statistics command.
Device# show platform software object-manager fp active statistics
Forwarding Manager Asynchronous Object Manager Statistics
Object update: Pending-issue: 0, Pending-acknowledgement: 0
Batch begin: Pending-issue: 0, Pending-acknowledgement: 0
Batch end: Pending-issue: 0, Pending-acknowledgement: 0
Command: Pending-acknowledgement: 0
Total-objects: 1378
Stale-objects: 0
Resolve-objects: 0
Childless-delete-objects: 4
Backplane-objects: 0
Error-objects: 0
Number of bundles: 0
Paused-types: 3