Run the show interface command from user EXEC mode. This command displays the interface configurations. Without any arguments, this command displays
the information for all the configured interfaces in the switch.
The following example displays the status of interfaces:
Examples
switch# show interface
fc1/1 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:0b:00:05:30:00:8d:de
Admin port mode is F
Port mode is F, FCID is 0x610000
Port vsan is 2
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 16
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
134 frames input, 8468 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
154 frames output, 46072 bytes
0 discards, 0 errors
1 input OLS, 1 LRR, 0 NOS, 0 loop inits
1 output OLS, 0 LRR, 1 NOS, 0 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
.
.
.
fc1/9 is trunking
Hardware is Fibre Channel, SFP is long wave laser cost reduced
Port WWN is 20:09:00:05:30:00:97:9e
Peer port WWN is 20:0b:00:0b:5f:a3:cc:00
Admin port mode is E, trunk mode is on
Port mode is TE
Port vsan is 100
Speed is 2 Gbps
Transmit B2B Credit is 255
Receive B2B Credit is 255
Receive data field Size is 2112
Beacon is turned off
Trunk vsans (admin allowed and active) (1,100,3000)
Trunk vsans (up) (1,100,3000)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
5 minutes input rate 280 bits/sec, 35 bytes/sec, 0 frames/sec
5 minutes output rate 176 bits/sec, 22 bytes/sec, 0 frames/sec
4609939 frames input, 8149405708 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
4638491 frames output, 7264731728 bytes
0 discards, 0 errors
3 input OLS, 9 LRR, 1 NOS, 0 loop inits
9 output OLS, 7 LRR, 1 NOS, 0 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
.
.
.
fc1/13 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:0d:00:05:30:00:97:9e
Admin port mode is auto, trunk mode is on
Port mode is F, FCID is 0x650100
Port vsan is 100
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 16
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
8696 frames input, 3227212 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
16799 frames output, 6782444 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
1 output OLS, 1 LRR, 0 NOS, 1 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
.
.
.
sup-fc0 is up
Hardware is Fibre Channel
Speed is 1 Gbps
139597 packets input, 13852970 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
139516 packets output, 16759004 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
You can also specify arguments (a range of interfaces or multiple specified interfaces) to display interface information.
You can specify a range of interfaces by issuing a command in the following format:
interface fc1/1 - 5 , fc2/5 - 7
 Note |
The spaces are required before and after the dash ( - ) and before and after the comma ( , ).
|
Examples
The following example displays the status of a range of interfaces:
switch# show interface fc3/13 , fc3/16
fc3/13 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:8d:00:05:30:00:97:9e
Admin port mode is FX
Port mode is F, FCID is 0x7b0300
Port vsan is 1
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 12
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
1856 frames input, 116632 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
1886 frames output, 887712 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 1 loop inits
1 output OLS, 1 LRR, 0 NOS, 1 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
fc3/16 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:90:00:05:30:00:97:9e
Admin port mode is FX
Port mode is F, FCID is 0x7d0100
Port vsan is 3000
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 12
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 504 bits/sec, 63 bytes/sec, 0 frames/sec
5 minutes output rate 520 bits/sec, 65 bytes/sec, 0 frames/sec
47050 frames input, 10311824 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
62659 frames output, 10676988 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
1 output OLS, 1 LRR, 0 NOS, 1 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
Examples
The following example displays the status of a specified interface:
switch# show interface fc2/2
fc2/2 is trunking
Port description is Trunk to Core-4
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:42:00:05:30:00:97:9e
Peer port WWN is 20:cc:00:05:30:00:50:9e
Admin port mode is E, trunk mode is on
Port mode is TE
Port vsan is 1
Speed is 2 Gbps
Transmit B2B Credit is 255
Receive B2B Credit is 255
Receive data field Size is 2112
Beacon is turned off
Belongs to port-channel 2
Trunk vsans (admin allowed and active) (1,100,3000)
Trunk vsans (up) (1)
Trunk vsans (isolated) (100,3000)
Trunk vsans (initializing) ()
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 32 bits/sec, 4 bytes/sec, 0 frames/sec
2214834 frames input, 98673588 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
2262415 frames output, 343158368 bytes
0 discards, 0 errors
1 input OLS, 1 LRR, 1 NOS, 0 loop inits
2 output OLS, 1 LRR, 0 NOS, 0 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
Examples
The following example displays the description of interfaces:
switch# show interface description
-------------------------------------------------------------------------------
Interface Description
-------------------------------------------------------------------------------
fc3/1 test intest
fc3/2 --
fc3/3 --
fc3/4 TE port
fc3/5 --
fc3/6 --
fc3/10 Next hop switch 5
fc3/11 --
fc3/12 --
fc3/16 --
-------------------------------------------------------------------------------
Interface Description
-------------------------------------------------------------------------------
port-channel 1 --
port-channel 5 --
port-channel 6 --
Examples
The following example displays a summary of information:
switch# show interface brief
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
-------------------------------------------------------------------------------
fc1/1 1 E on trunking swl TE 2 1
fc1/2 1 E on trunking swl TE 2 1
fc1/3 1 auto on SFPAbsent -- -- --
fc1/4 1 auto on SFPAbsent -- -- --
fc1/5 3000 auto on up swl F 2 --
...
fc2/2 1 E on trunking swl TE 2 2
fc2/3 1 auto on down c1610 -- --
fc2/4 1 auto on down c1590 -- --
fc2/5 3000 auto on notConnected lwcr -- --
fc2/6 1 auto on SFPAbsent -- -- --
...
fc3/16 3000 FX -- up swl F 2 --
fc3/17 1 FX -- SFPAbsent -- -- --
...
-------------------------------------------------------------------------------
Interface Status IP Address Speed MTU
-------------------------------------------------------------------------------
GigabitEthernet4/1 SFPAbsent -- auto 1500
...
GigabitEthernet4/6 down 10.1.1.2/8 auto 3000
GigabitEthernet4/7 down 10.1.1.27/24 auto 1500
GigabitEthernet4/8 down -- auto 1500
-------------------------------------------------------------------------------
Interface Status Oper Mode Oper Speed
(Gbps)
-------------------------------------------------------------------------------
iscsi4/1 down --
...
-------------------------------------------------------------------------------
Interface Status Speed
(Gbps)
-------------------------------------------------------------------------------
sup-fc0 up 1
-------------------------------------------------------------------------------
Interface Status IP Address Speed MTU
-------------------------------------------------------------------------------
mgmt0 up 172.19.48.96/25 100 Mbps 1500
-------------------------------------------------------------------------------
Interface Vsan Admin Status Oper Oper
Trunk Mode Speed
Mode (Gbps)
-------------------------------------------------------------------------------
port-channel 1 1 on trunking TE 4
port-channel 2 1 on trunking TE 4
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status Oper Profile Port-channel
Mode Trunk Mode
Mode
-------------------------------------------------------------------------------
fcip10 1 auto on notConnected -- 10 --
Examples
The following example displays a summary of information:
switch# show interface counters
fc3/1
5 minutes input rate 24 bits/sec, 3 bytes/sec, 0 frames/sec
5 minutes output rate 16 bits/sec, 2 bytes/sec, 0 frames/sec
3502 frames input, 268400 bytes
0 discards, 0 CRC, 0 unknown class
0 too long, 0 too short
3505 frames output, 198888 bytes
0 discards
1 input OLS, 1 LRR, 1 NOS, 0 loop inits
2 output OLS, 1 LRR, 1 NOS, 0 loop inits
1 link failures, 1 sync losses, 1 signal losses
.
.
.
fc9/8
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
0 frames input, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards, 0 CRC, 0 unknown class
0 too long, 0 too short
0 frames output, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
0 output OLS, 0 LRR, 0 NOS, 0 loop inits
0 link failures, 0 sync losses, 0 signal losses
16 receive B2B credit remaining
3 transmit B2B credit remaining.
. . .
sup-fc0
114000 packets input, 11585632 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
113997 packets output, 10969672 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
mgmt0
31557 packets input, 2230860 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
26618 packets output, 16824342 bytes, 0 underruns
0 output errors, 0 collisions, 7 fifo
0 carrier errors
vsan1
0 packets input, 0 bytes, 0 errors, 0 multicast
0 packets output, 0 bytes, 0 errors, 0 dropped
.
.
.
port-channel 1
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
0 frames input, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards, 0 CRC, 0 unknown class
0 too long, 0 too short
0 frames output, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
0 output OLS, 0 LRR, 0 NOS, 0 loop inits
0 link failures, 0 sync losses, 0 signal losses
 Note |
Interfaces 9/8 and 9/9 are not trunking ports and display Class 2, 3, and F information as well.
|
Examples
The following example displays the brief counter information of interfaces:
switch# show interface counters brief
-------------------------------------------------------------------------------
Interface Input (rate is 5 min avg) Output (rate is 5 min avg)
----------------------------- -----------------------------
Rate Total Rate Total
Mbits/s Frames Mbits/s Frames
-------------------------------------------------------------------------------
fc3/1 0 3871 0 3874
fc3/2 0 3902 0 4232
fc3/3 0 3901 0 4138
fc3/4 0 3895 0 3894
fc3/5 0 3890 0 3897
fc9/8 0 0 0 0
fc9/9 0 5 0 4
fc9/10 0 4186 0 4182
fc9/11 0 4331 0 4315
-------------------------------------------------------------------------------
Interface Input (rate is 5 min avg) Output (rate is 5 min avg)
----------------------------- -----------------------------
Rate Total Rate Total
Mbits/s Frames Mbits/s Frames
-------------------------------------------------------------------------------
port-channel 1 0 0 0 0
port-channel 2 0 3946 0 3946
Examples
You can run the show
interface
transceiver command only on a switch in the Cisco MDS 9100 Series if the SFP is present, as show in the following example:
switch# show interface transceiver
fc1/1 SFP is present
name is CISCO-AGILENT
part number is QFBR-5796L
revision is
serial number is A00162193
fc-transmitter type is short wave laser
cisco extended id is unknown (0x0)
...
fc1/9 SFP is present
name is FINISAR CORP.
part number is FTRJ-1319-7D-CSC
revision is
serial number is H11A6ER
fc-transmitter type is long wave laser cost reduced
cisco extended id is unknown (0x0)
...
Examples
The following example displays the entire running configuration, with information about all the interfaces. The interfaces
have multiple entries in the configuration files to ensure that the interface configuration commands execute in the correct
order when the switch reloads.
switch# show running-config
...
interface fc9/1
switchport speed 2000
...
interface fc9/1
switchport mode E
...
interface fc9/1
channel-group 11 force
no shutdown
Examples
The following example displays the running configuration information for a specified interface. The interface configuration
commands are grouped together:
switch# show running-config interface fc1/1
interface fc9/1
switchport speed 2000
switchport mode E
channel-group 11 force
no shutdown
Displays the Running Configuration after the System Default Switchport Mode F Command is Executed displays the running configuration after the system
default
switchport
mode
F
command is executed.
Examples
The following example displays the running configuration after the system
default
switchport
mode
F
command is executed:
switch# show running-config
version 3.1(3)
system default switchport mode F
interface fc4/1
interface fc4/2
interface fc4/3
interface fc4/4
interface fc4/5
interface fc4/6
interface fc4/7
interface fc4/8
interface fc4/9
interface fc4/10
Examples
The following example displays the running configuration after two interfaces are individually configured for FL mode:
switch# show running-config
version 3.1(3)
system default switchport mode F
interface fc4/1
switchport mode FL
interface fc4/2
interface fc4/3
switchport mode FL
interface fc4/4
interface fc4/5
interface fc4/6
interface fc4/7
interface fc4/8
interface fc4/9
interface fc4/1
Examples
The following example displays interface information in a brief format after the system default switchport mode F command is executed:
switch# show interface brief
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
-------------------------------------------------------------------------------
fc4/1 1 F -- notConnected swl -- --
fc4/2 1 F -- notConnected swl -- --
fc4/3 1 F -- notConnected swl -- --
fc4/4 1 F -- notConnected swl -- --
fc4/5 1 F -- sfpAbsent -- -- --
fc4/6 1 F -- sfpAbsent -- -- --
fc4/7 1 F -- sfpAbsent -- -- --
fc4/8 1 F -- sfpAbsent -- -- --
fc4/9 1 F -- sfpAbsent -- -- --
Examples
The following example displays interface information in a brief format after two interfaces are individually configured for
FL mode:
switch# show interface brief
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
-------------------------------------------------------------------------------
fc4/1 1 FL -- notConnected swl -- --
fc4/2 1 F -- notConnected swl -- --
fc4/3 1 FL -- notConnected swl -- --
fc4/4 1 F -- notConnected swl -- --
fc4/5 1 F -- sfpAbsent -- -- --
fc4/6 1 F -- sfpAbsent -- -- --
fc4/7 1 F -- sfpAbsent -- -- --
fc4/8 1 F -- sfpAbsent -- -- --
fc4/9 1 F -- sfpAbsent -- -- --
fc4/10 1 F -- sfpAbsent -- -- --