S Commands


This chapter describes the Cisco NX-OS Fibre Channel, virtual Fibre Channel, and Fibre Channel over Ethernet (FCoE) commands that begin with S.

san-port-channel persistent

To convert an autocreated SAN port channel to a persistent SAN port channel, use the san-port-channel persistent command.

san-port-channel port-channel-id persistent

Syntax Description

port-channel-id

Port channel ID. The range is from 1 to 128.

persistent

Converts the autocreated SAN port channel to a persistent SAN port channel


Command Default

None

Command Modes

EXEC mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.


Usage Guidelines

This command is not reversible. A user-created channel group cannot be converted to an autocreated channel group.When the san-port-channel persistent command is applied to an autocreated channel group, the channel group number does not change and the properties of the member ports change to those of a user-created channel group. The channel mode remains active.

Examples

This example shows how to change the properties of an autocreated channel group to a persistent channel group:

switch# san-port-channel 10 persistent
 
   

Related Commands

Command
Description

san-port-channel protocol

Enables the SAN port channel protocol.

show interface port-channel

Displays SAN port channel interface information.

show port-channel

Displays SAN port channel information.


scsi-target

To configure SCSI target discovery, use the scsi-target command. To remove SCSI target discovery, use the no form of this command.

scsi-target {auto-poll [vsan vsan-id] | discovery | ns-poll [vsan vsan-id] | on-demand [vsan vsan-id]}

no scsi-target {auto-poll [vsan vsan-id] | discovery | ns-poll [vsan vsan-id] | on-demand [vsan vsan-id]}

Syntax Description

auto-poll

Configures SCSI target auto-polling globally or per VSAN.

vsan vsan-id

(Optional) Specifies a VSAN ID. The range is from 1 to 4093.

discovery

Configures SCSI target discovery.

ns-poll

Configures SCSI target name-server polling globally or per VSAN.

on-demand

Configures SCSI targets on-demand globally or per VSAN.


Command Default

SCSI target discovery for each option is enabled.

Command Modes

Global configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.


Usage Guidelines

Automatic global SCSI target discovery is on by default. Discovery can also be triggered for specific VSANs using on-demand, name server polling, or auto-polling options. All options are on by default. Use the no scsi-target discovery command to turn off all discovery options. You can also turn off specific options by using the no form of this command.

Examples

This example shows how to configure a SCSI target auto-polling discovery for VSAN 1:

switch(config)# scsi-target auto-poll vsan 1
 
   

This example shows how to remove the SCSI target auto-polling discovery for VSAN 1:

switch(config)# no scsi-target auto-poll vsan 1
 
   

This example shows how to configure a SCSI target discovery:

switch(config)# scsi-target discovery
 
   

This example shows how to configure a SCSI target ns-polling discovery for VSAN 1:

switch(config)# scsi-target ns-poll vsan 1
 
   

This example shows how to remove a SCSI target ns-polling discovery for VSAN 1:

switch(config)# no scsi-target ns-poll vsan 1
 
   

This example shows how to configure a SCSI target on-demand discovery for VSAN 1:

switch(config)# scsi-target on-demand vsan 1
 
   

This example shows how to remove a SCSI target on-demand discovery for VSAN 1:

switch(config)# no scsi-target on-demand vsan 1
 
   

Related Commands

Command
Description

discover scsi-target

Discovers SCSI targets on local storage to the switch or remote storage across the fabric.

show scsi-target

Displays information about existing SCSI target configurations.


shutdown

To change the virtual Fibre Channel interface or SAN port channel interface state to administrative down, use the shutdown command. To enable an interface, use the no form of this command.

shutdown [force]

no shutdown

Syntax Description

force

(Optional) Specifies that the interface state be forcefully changed to administrative down.


Command Default

Enabled

Command Modes

Virtual Fibre Channel interface configuration mode
SAN port channel configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.

5.0(2)N1(1)

The shutdown command was separated from the interface vfc command.

5.1(3)N1(1)

The shutdown keyword was separated from the interface san-port-channel command.

Note On a Cisco Nexus 5000 Series that runs a Cisco NX-OS release prior to 5.1(3)N1(1), this command was a keyword of the interface san-port-channel command.


Usage Guidelines

Use the no shutdown command to enable the interface.

Examples

This example shows how to disable virtual Fibre Channel interface 3:

switch# configure terminal
switch(config)# interface vfc 3 
switch(config-if)# shutdown 
switch(config-if)# 
 
   

This example shows how to enable virtual Fibre Channel interface 3:

switch# configure terminal
switch(config)# interface vfc 3
switch(config-if)# no shutdown
switch(config-if)# 
 
   

This example shows how to forcefully bring a SAN port channel interface to the administratively down state:

switch# configure terminal
switch(config)# interface san-port-channel 3
switch(config-if)# shutdown force
switch(config-if)# 
 
   

Related Commands

Command
Description

interface san-port-channel

Configures a SAN port channel interface.

interface vfc

Configures a virtual Fibre Channel interface.

show interface vfc

Displays the specified VFC interface, attributes, and status.

show interface vfc

Displays the specified VFC interface, attributes, and status.


shutdown lan (FCoE)

To shut down the Ethernet traffic on a Fibre Channel over Ethernet (FCoE) link, use the shutdown lan command. To restore Ethernet traffic, use the no form of this command.

shutdown lan

no shutdown lan

Syntax Description

This command has no arguments or keywords.

Command Default

Not shut down.

Command Modes

Interface configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.


Usage Guidelines

Use this command to shut down Ethernet traffic on the interface. If the interface is part of an FCoE VLAN, the shutdown has no impact on the FCoE traffic.

Examples

This example shows how to shut down an Ethernet interface on an FCoE link:

switch(config)# interface ethernet 2/1 
switch(config-if)# shutdown lan 
switch(config-if)#
 
   

This example shows how to restore traffic on an interface after you have shut down, or disabled, the interface:

switch(config)# interface ethernet 2/1 
switch(config-if)# no shutdown lan 
switch(config-if)#
 
   

Related Commands

Command
Description

fcoe

Configures FCoE parameters.


switchport (Fibre Channel)

To configure a switch port parameter on a Fibre Channel, use the switchport command. To discard the configuration, use the no form of this command.

switchport
{fcrxbbcredit {number [mode E | F] | default} |
mode {F | NP | SD} |
speed {1000 | 2000 | 4000 | 8000 | auto [max 2000]} |
trunk {allowed vsan {[add] vsan-id | all} | mode {auto | off | on}}}

no switchport {fcrxbbcredit| mode | speed | trunk {allowed vsan [[add] vsan-id | all] | mode}}

Syntax Description

fcrxbbcredit

Configures receive BB_credit for the port.

number

Receive BB_credit. The range is from 1 to 240.

mode

Configures receive BB_credit for the specific port mode.

E

Configures receive BB_credit for E or TE port mode.

F

Configures receive BB_credit for F port mode.

default

Configures default receive BB_credits depending on the port mode and capabilities.

mode

Configures the port mode.

F

Configures F port mode.

NP

Configures N port proxy mode. NP mode is valid only when the switch is operating in N-Port Virtualizer (NPV) mode.

SD

Configures SD port mode.

speed

Configures the port speed.

1000

Configures the 1000-Mbps speed.

2000

Configures the 2000-Mbps speed.

4000

Configures the 4000-Mbps speed.

8000

Configures the 8000-Mbps speed.

auto

Configures autosense speed.

max 2000

(Optional) Configures 2 Gbps as the maximum bandwidth reserved in auto mode for 24-port and 48-port 4-Gbps switching module interfaces.

trunk

Configures trunking parameters on the interface.

allowed

Specifies the allowed list for interface(s).

vsan

Configures the VSAN range.

add

(Optional) Adds the VSAN ID to the allowed VSAN list.

vsan-id

VSAN ID. The range is from 1 to 4093.

all

Adds all the VSANs to the allowed VSAN list.

mode

Configures the trunking mode.

auto

Configures automatic trunking mode.

off

Disables the trunking mode.

on

Enables the trunking mode.


Command Default

The EISL encapsulation is disabled.
The default receive data buffer size is 2112 bytes.
The port mode is auto.
The speed is auto.
The maximum auto speed is 2000.
The trunk mode is on.

Command Modes

Interface configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.


Usage Guidelines

You can specify a range of interfaces by entering a command with the following example format:

interface fc 1/1 - 5, fc 2/5 - 7 
 
   

The port speed on an interface determines the amount of shared resources available to the ports in the port group. Port group resources are reserved even though the bandwidth is not used. For example, if an interface is configured for autosensing (auto), then 4 Gbps of bandwidth is reserved even though the maximum operating speed is 2 Gbps. For the same interface, if autosensing with a maximum speed of 2 Gbps (auto max 2000) is configured, then only 2 Gbps of bandwidth is reserved and the unused 2 Gbps is shared with the other interface in the port group.

When configuring port modes, observe the following guidelines:

Auto port mode and E port mode cannot be configured in shared rate mode.

Shared to dedicated ports should be configured in this order: speed, port mode, credit.

Dedicated to shared ports should be configured in this order: credit, port mode, speed.

Examples

This example shows how to configure the switch port parameters for a Fibre Channel interface:

switch(config)# interface fc 2/3
switch(config-if)# switchport description techdocsSample
switch(config-if)# switchport mode E
switch(config-if)# switchport trunk mode auto
switch(config-if)# switchport trunk allowed vsan all
switch(config-if)# switchport trunk allowed vsan 3
switch(config-if)# switchport trunk allowed vsan add 2
switch(config-if)# switchport fcrxbbcredit 20
 
   

This example shows how to configure the mode of a virtual Fibre Channel interface:

switch(config)# interface vfc 2
switch(config-if)# switchport mode F
 
   

Related Commands

Command
Description

fcrxbbcredit extended enable

Enables extended BB_credits on the switch.

show interface

Displays an interface configuration for a specified interface.


switchport (SAN PortChannel)

To configure switch port parameters on a SAN port channel interface, use the switchport command. To discard the configuration, use the no form of this command.

switchport {description line | mode {NP | auto} | speed {1000 | 2000 | 4000 | 8000 | auto} | trunk {allowed vsan {vsan-id | add vsan-id | all} | mode {auto | on | off}}}

no switchport {description | mode | speed | trunk {allowed vsan [vsan-id | add vsan-id | all] | mode}}

Syntax Description

description line

Specifies a description for the interface. The description can be a maximum of 80 alphanumeric characters.

mode

Configures receive BB_credit for the specific port mode.

NP

Configures the SAN port channel interface as an N-Port Virtualizer (NPV) port.

auto

Configures autosense mode.

speed

Configures the port speed.

1000

Configures the 1000-Mbps speed.

2000

Configures the 2000-Mbps speed.

4000

Configures the 4000-Mbps speed.

8000

Configures the 8000-Mbps speed.

auto

Configures the autonegotiation speed.

trunk

Configures trunking parameters on the interface.

allowed

Specifies the allowed list for interface(s).

vsan

Configures the VSAN range.

vsan-id

VSAN ID. The range is from 1 to 4093.

add

Adds the VSAN ID to the allowed VSAN list.

all

Adds all the VSANs to the allowed VSAN list.

mode

Configures the trunking mode.

on

Enables the trunking mode.

off

Disables the trunking mode.


Command Default

Disabled

Command Modes

SAN port channel configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.

5.1(3)N1(1)

The E port was dropped from this release.

Support for the N-Port Virtualizer (NPV) port and 8000-Mbps port speed was added.

The switchport keyword was separated from the interface san-port-channel command and documented as a separate command.

Note On a Cisco Nexus 5000 Series that runs a Cisco NX-OS release prior to 5.1(3)N1(1), this command was a keyword of the interface san-port-channel command.


Usage Guidelines

This command does not require a license.

Examples

This example shows how to configure switch port parameters for a SAN port channel interface:

switch# configure terminal
switch(config)# interface san-port-channel 3
switch(config-if)# switchport description SAN Port Channel 3 Configuration
switch(config-if)# switchport speed 2000
switch(config-if)# switchport mode NP
switch(config-if)#
 
   

This example shows how to remove the switch port configuration for a SAN port channel interface:

switch# configure terminal
switch(config)# interface san-port-channel 3
switch(config-if)# no switchport description
switch(config-if)# no switchport speed
switch(config-if)#
 
   

Related Commands

Command
Description

show interface

Displays an interface configuration for a specified interface.

shutdown

Disables and enables an interface.

channel mode active (SAN PortChannel)

Configures a SAN port channel interface as an active port channel port.


switchport (virtual Fibre Channel interface)

To configure a switch port parameter on a virtual Fibre Channel interface, use the switchport command. To discard the configuration, use the no form of this command.

switchport mode {E | F | NP}

no switchport mode

Syntax Description

switchport mode

Specifies the mode of the virtual Fibre Channel interface.

E

Configures the virtual Fibre Channel interface as a virtual E (VE) port.

F

Configures the virtual Fibre Channel interface as an F port. This is the default mode.

NP

Configures the virtual Fibre Channel interface as an N-Port Virtualizer (NPV) port.


Command Default

F port mode

Command Modes

Virtual Fibre Channel interface configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.

5.0(2)N1(1)

The bind, description, shutdown, and switchport commands were separated from the interface vfc command.

5.0(2)N2(1)

Support for virtual E (VE) port was added.

5.0(3)N3(1)

Support for N-Port Virtualizer (NPV) port was added.


Usage Guidelines

The Ethernet or EtherChannel interface that you bind to the virtual Fibre Channel interface must be a trunk port.

You can bind an F port to a member of a virtual port channel (vPC) if it is the only member of the vPC on the local switch. Because of limitations in the hardware, you cannot bind multiple virtual Fibre Channel interfaces to multiple members of the vPC. You can, however, bind an F port to non-vPC EtherChannels.

By default, a VE port is enabled for trunk mode. A VE port cannot be bound to a MAC address.

VE-capable ports allow the discovery and instantiation of virtual links between Cisco Nexus 5000 Series switches and SAN switches, which enables multi-hop FCoE on the switch.

Examples

This example shows how to configure an F port on virtual Fibre Channel interface 3:

switch(config)# interface ethernet 1/1 
switch(config-if)# switchport mode trunk 
switch(config-if)# exit 
switch(config)# interface vfc 3 
switch(config-if)# bind interface ethernet 1/1 
switch(config-if)# switchport mode F 
switch(config-if)# 
 
   

This example shows how to configure a VE port on virtual Fibre Channel interface 3:

switch(config)# interface ethernet 1/1 
switch(config-if)# switchport mode trunk 
switch(config-if)# exit 
switch(config)# interface vfc 3 
switch(config-if)# bind interface ethernet 1/1 
switch(config-if)# switchport mode E 
switch(config-if)# 
 
   

Related Commands

Command
Description

interface vfc

Configures a virtual Fibre Channel interface.

show interface vfc brief

Displays the specified VFC interface, including its attributes and status.

shutdown

Disables and enables an interface.

switchport mode trunk

Configures an Ethernet interface as a trunk port.


switchport mode trunk

To configure an Ethernet interface as a trunk port, use the switchport mode trunk command. To remove the configuration, use the no form of this command.

switchport mode trunk

no switchport mode trunk

Syntax Description

This command has no arguments or keywords.

Command Default

None

Command Modes

Interface configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.

5.0(2)N1(1)

Switchport trunk mode is on by default for virtual Fibre Channel interfaces.


Usage Guidelines

The Ethernet interface must be configured as a trunk port to allow both Fibre Channel and Ethernet traffic on the same interface.


Note On Cisco NX-OS 5.0(2)N1(1), the switchport trunk mode is on by default for virtual Fibre Channel interfaces and cannot be configured.


Examples

This example shows how to enable the trunk mode for interface Ethernet 2/1:

switch(config)# interface ethernet 2/1 
switch(config-if)# switchport mode trunk 
switch(config-if)# 
 
   

Related Commands

Command
Description

show interface switchport

Displays information on all interfaces configured as switch ports.


switchport ignore bit-errors

To prevent the detection of bit error threshold events from disabling the interface on Fibre Channel interfaces, use the switchport ignore bit-errors command. To revert to the default, use the no form of this command.

switchport ignore bit-errors

no switchport ignore bit-errors

Syntax Description

This command has no arguments or keywords.

Command Default

None

Command Modes

Interface configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.


Usage Guidelines

The bit error rate threshold is used by the switch to detect an increased error rate before performance degradation seriously affects traffic.

Bit errors can occur for the following reasons:

Faulty or bad cable

Faulty or bad SFP

SFP is specified to operate at 1 Gbps but is used at 2 Gbps

Short haul cable is used for long haul or long haul cable is used for short haul

Momentary sync loss

Loose cable connection at one or both ends

Improper SFP connection at one or both ends

A bit error rate threshold is detected when 15 error bursts occur in a 5-minute period. By default, the switch disables the interface when the threshold is reached. You can enter a shutdown/no shutdown command sequence to reenable the interface.

Regardless of the setting of the switchport ignore bit-errors command, the switch generates a syslog message when bit error threshold events are detected.

Examples

This example shows how to prevent the detection of bit error events from disabling the interface:

switch(config)# interface fc2/1
switch(config-if)# switchport ignore bit-errors
 
   

This example shows how to allow the detection of bit error events from disabling the interface:

switch(config)# interface fc2/1
switch(config-if)# no switchport ignore bit-errors
 
   

Related Commands

Command
Description

show interface

Displays interface information.


system default switchport

To configure port attributes for Fibre Channel interfaces, use the system default switchport command. To disable port attributes, use the no form of this command.

system default switchport {shutdown | trunk mode {auto | off | on}}

no system default switchport {shutdown | trunk mode {auto | off | on}}

Syntax Description

shutdown

Disables or enables switch ports by default.

trunk

Configures the trunking parameters as a default.

mode

Configures the trunking mode.

auto

Enables autosense trunking.

off

Disables trunking.

on

Enables trunking.


Command Default

Enabled

Command Modes

Global configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.


Usage Guidelines

Attributes configured using this command are applied globally to all future switch port configurations, even if you do not individually specify them at that time.

This command changes the configuration of the following ports to administrative mode F:

All ports that are down.

All F ports that are up, whose operational mode is F, and whose administrative mode is not F.

This command does not affect non-F ports that are up; however, if non-F ports are down, this command changes the administrative mode of those ports.

Examples

This example shows how to configure a port shutdown:

switch(config)# system default switchport shutdown
 
   

This example shows how to configure the trunk mode:

switch(config)# system default switchport trunk mode auto
 
   

Related Commands

Command
Description

show system default switchport

Displays default values for switch port attributes.

show interface brief

Displays Fibre Channel port modes.


system default zone default-zone permit

To configure default values for a zone, use the system default zone default-zone permit command. To revert to the defaults, use the no form of this command.

system default zone default-zone permit

no system default zone default-zone permit

Syntax Description

This command has no arguments or keywords.

Command Default

No default values for zones.

Command Modes

Global configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.


Usage Guidelines

This command defines the default values for the default zone for all Virtual SANs (VSANs). The default values are used when you initially create a VSAN and it becomes active. If you do not want to use the default values, use the zone default-zone permit vsan command to define the operational values for the default zone.

The system default zone default-zone permit command should only be used with VSANs that have not yet been created; it has no effect on existing VSANs.

Because VSAN 1 is the default VSAN and is always present, this command has no effect on it.

Examples

This example shows how to set the default zone to use the default values:

switch(config)# system default zone default-zone permit
 
   

This example shows how to restore the default setting:

switch(config)# no system default zone default-zone permit
 
   

Related Commands

Command
Description

zone default-zone permit vsan

Defines whether a default zone (nodes not assigned a created zone) permits or denies access to all in the default zone.

show system default zone

Displays default values for the default zone.


system default zone distribute full

To configure default values for distribution to a zone set, use the system default zone distribute full command. To revert to the defaults, use the no form of this command.

system default zone distribute full

no system default zone distribute full

Syntax Description

This command has no arguments or keywords.

Command Default

Distribution to active zone sets only.

Command Modes

Global configuration mode

Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.


Usage Guidelines

This command distributes the default values for the default zone to all Virtual SANs (VSANs). The default values are used when you initially create a VSAN and it becomes active. If you do not want to use the default values, use the zoneset distribute full vsan command to distribute the operational values for the default zone.

The system default zone distribute full command should only be used with VSANs that have not yet been created; it has no effect on existing VSANs.

Because VSAN 1 is the default VSAN and is always present, this command has no effect on it.

Examples

This example shows how to distribute the default values to the full zone set:

switch(config)# system default zone distribute full
 
   

This example shows how to distribute the default values to the active zone set only:

switch(config)# no system default zone distribute full
 
   

Related Commands

Command
Description

zoneset distribute full vsan

Distributes the operational values for the default zone to all zone sets.

show system default zone

Displays default values for the default zone.